Planned system upgrades from 2020-10-03 22:15 CDT to 2020-10-03 22:30 CDT

Scheduled maintenance Pymt Shops Pymt Gateway Pymt Application Service Pymt Receipts Pymt Dashboard
15 minutes

Updates

Scheduled

We’re making needed changes to our backend systems, we expect limited interruptions to out services.

We apologize but upgrades like this are necessary to bring you the best possible service.

September 19, 2020 · 22:15 CDT
Monitoring

Updates are progressing, validation is starting now.

September 19, 2020 · 22:15 CDT
Update

Systems are updated and fully operational.

September 19, 2020 · 22:15 CDT
Update

Maintenance beginning in 10 minutes.

September 19, 2020 · 22:15 CDT

← Back