Planned system upgrades from 2020-11-28 21:15 CST to 2020-11-28 21:30 CST

Scheduled maintenance Pymt Shops Pymt Gateway Pymt Application Service Pymt Receipts Pymt Dashboard
15 minutes

Updates

Scheduled

We’re making needed changes to our backend systems, we expect limited interruptions to out services.

We apologize but upgrades like this are necessary to bring you the best possible service.

November 14, 2020 · 21:15 CST
Monitoring

Updates are progressing, validation is starting now.

November 14, 2020 · 21:15 CST
Update

Systems are updated and fully operational.

November 14, 2020 · 21:15 CST
Update

Maintenance beginning in 10 minutes.

November 14, 2020 · 21:15 CST

← Back